Javascript bot programming using Gemini API, NodeJS and CryptoCompare - DISCUSSION

#21

Gemini not working in South Africa. Is it by any chance possible to give instructions to connect to Bitmex API?

1 Like
#22

Thank you Jebel for your quick response, you are right I typed “sandbox” wrong but still the error is still there, its pointing on a “full-stop” at the beginning of the bottom line 7

#23

Attached is a screenshot of an error on line 7 and I do not know whats wrong

#24

we may offer that in the future, for now we only have Gemini unfortunately

#25

Please don’t take pictures like that as we can’t see your whole code, paste your code here in full

#26

It won’t be covered in this iteration of the class (hopefully in addendum), but you can install CCXT package via NPM and run through the examples etc… if Gemini doesn’t work for you in South Africa, this will help you get through the course.

It’s a unified syntax so you can use the same pkg to connect to multiple exchanges… I’m using it for Bitmex & Binance. Anywho… it’s not what this course covers, so you won’t be able to ask specific questions for help here, however it will work for you and depending on your level of understanding and tenacity to learn, it may be what you’re looking for.

Best of luck ;o)

1 Like
#27

Hi Michael, your line 7 shouldn’t have a semi-column at the end.

#28

Hi Jebel,
Thank you for your help, you are a star

1 Like
#30

Thank you. It worked and I was able to connect to Bitmex. I did not manage to connect to Bitmex Testnet but manage to connect to the “real” Bitmex which is fine.

1 Like
#32

Gemini doesnt work in my country… I tried BitMEX but i couldnt get order information.
i got an error as “unexpected token”…
i see Bitmex is a little different but when you get file from npm you see all files is in it. Everything is almost ready. They provide codes already. but not for beginners …

Can you cover it for BitMEX too…Thank you.

#33

Same here. The problem is that we cannot even try gemini and afterwards try to adopt to bitmex.

Did anybody find out how to send an order to bitmex using bitmex-realtime-api? I read alot at https://www.bitmex.com/api/explorer/#!/Order/Order_new but I don’t know how to write the JS code to open an order. I dont even know where to look it up. ;(

#34

oh, so sad, Gemini exchange is not available in Ukraine . can’t register to get api keys ( Maybe someone knows exchanges that has all needed tools ( demo money, sandbox, api) and is available for entire world, so I will continue practicing the same things that we learn on this course but with other exchange ?
Thanks)

#35

I’ll try out on Bitmex

#36

Hey,
I have installed yarn but in the next step when try to install gemini api has problem to recognize it. Someone have an idea what could be the problem? Thank you

PS /Users/lukashoryna/Desktop/Ivan On Tech> npm install yarn ""global

npm WARN tradingbot@1.0.0 No repository field.

  • global@4.3.2

  • yarn@1.15.2

updated 2 packages and audited 5 packages in 2.496s

found 0 vulnerabilities

PS /Users/lukashoryna/Desktop/Ivan On Tech> yarn add gemini-api

yarn : The term ‘yarn’ is not recognized as the name of a cmdlet, function, script file, or operable program.

Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

At line:1 char:1

  • yarn add gemini-api

  • 
    
  • CategoryInfo : ObjectNotFound: (yarn:String) [], CommandNotFoundException

  • FullyQualifiedErrorId : CommandNotFoundException

#37

Hello!
I’m really new to all this.
I’m using binance API


Just wondering how can I get a number response, without symbol etc.
Thank you!

#38

Hi Ivan,

It looks like Yarn is not working for me: “-bash: yarn: command not found”
I’m using a MacBook Pro. Any suggestions?

#39

Hey Lukas,

It seems I have the same issue with my macbook. Didi you find the solution? Pls let me know so I can apply the same. Thanks

#40

Hi Ivan,

On building MA Strategy, you did a copy paste and line 26 has “exchange.marketBuyBitcoin” and so is line 38 “exchange.marketBuyBitcoin” but isn’t it suppose to be “exchange.marketSellBitcoin”. If someone already pointed out in the forum, then please ignore it.

Excellent course … Gemini works fine in New Zealand … :smiley:

Cheers
Imran

#41

Hey Andy,

unfortunately not. Tried to check some youtube videos (https://www.youtube.com/watch?v=DAnf4XUUjkg&t=309s) and found the guy presenting to get over with Homebrew (https://brew.sh/) but it doesn’t work for me either. Try and maybe you will have more luck with that.

#42

Aah I see. Let me try and see.

Thanks bro.