EOS Installation Discussion

Welcome to the thread about EOS Installation. Here you can discuss everything about the eos installation and potential problems that you might stumble upon.

2 Likes

Filip, it would be helpful during the EOS installation module if you added more explanation to each of parameters when running nodeos.

Command from module:
nodeos -e -p eosio --genesis-json eos.json --delete-all-blocks --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin --contracts-console

Hi all ,

siege17 hi , did this command go through without errors for you ?

nodeos -e -p eosio --genesis-json eos.json --delete-all-blocks --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin --contracts-console

sorry or this command nodeos --extract-genesis.json filipgen.json . Im running in to some funny errors when trying to run this command as per the tutorial video

1 Like

Could you post the error here? Did the installation and build pass successfully?

hi filip ,

yes i will post as soon as I have finished re running it with some changes . I will post immediately after
.I think the new compilation may be more successful i now will run that command again and post back the result

hi again ,
ok so I ran the eos build sh and it went through , after this the eos system page appeared and i had some commands to check the installation. The first 28 checks passed successfully but then the nodes failed

Total Test time (real) = 1656.80 sec

The following tests FAILED:
29 - nodeos_run_test (Failed)
30 - nodeos_run_remote_test (Failed)
31 - distributed-transactions-test (Failed)
32 - distributed-transactions-remote-test (Failed)

Did you do the sudo make install? Or do you have anything else running on port 8888?

1 Like

got it filip

i ran the rest of the instructions and then retested and it now is ok
thankyou so far for the very quick reply it is much appreciated

1 Like

start at 10:20 if ubuntu and not win/virtual box. maybe add a note on the slide @filip

Running linux as subsystem is a better option for installing on windows. You share the same resources and file structure.

Windows Store has one click install for Ubuntu once you enable the Microsoft-Windows-Subsystem-Linux feature as seen in the article you provided.

You install and configure Unbuntu then you can pick up where Filip installs eos via git at 10:30.

Great course,
Shawn

2 Likes

I was able to get nodeos running blocks successfully the first time with :
sudo nodeos -e -p eosio --genesis-json shawnrmossgen.json --delete-all-blocks --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin

I can stop nodeos and start it again with :
sudo nodeos -e -p eosio --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin

But now when I run :
cleos get info
Error 3110001: Missing Chain API PluginEnsure that you have eosio::chain_api_plugin added to your node’s configuration!Error Details:
Chain API plugin is not enabled

When nodeos does not shut down properly I get:

sudo nodeos -e -p eosio --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin[sudo] password for mocypher:2632771ms thread-0 chain_plugin.cpp:151 plugin_initialize ] initializing chain plugin
2632797ms thread-0 main.cpp:123 main ] database dirty flag set (likely due to unclean shutdown): replay required

Shawn

1 Like

I would try to run it with the replay-blockchain flag. So the full command becomes nodeos -e -p eosio --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin --replay-blockchain

1 Like

Thanks filip. That cleared the issue I was having with the database dirty flag.

I then started getting - Not producing block because the irreversible block is too old.

My fix:
nodeos -e -p eosio --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin --max-irreversible-block-age 99999999

Shawn.

Fillip, (or someone) – I have run the build script and validated with test 36/36 no issues, But I go to launch the Node testnet and I get “Permission denied”. Any hints on where I’m missing something? I am a newbie, so I’m sure it’s a simple step. Cheers.
I think it might have something to do with Keosd and creating wallet and accounts.

Try starting nodeos with sudo infront of it. So begin the line with sudo. “Sudo nodeos -e -p…”

You are the Man! …Thanks
I have no idea why that worked

When I try to run sudo nodeos -e -p eosio --genesis-json filipgen.json --delete-all-blocks --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin --contracts-console I get this error:

06

Can someone please help me?

1 Like

Try to add the flag --max-irreversible-block-age 1000000

Thank you, it helped